Delayed Message Integration
Incident Report for Eleos Technologies
Resolved
Our error rates for sending push notifications to devices have remained normal since 14:15 UTC, and we are delivering message notifications to users within a timely manner.

Our queue of messages that need integrated to customer's messaging services has remained low since 13:37 UTC, and we are integrating messages within our normal time frame.

This incident was caused by an increase in response times from Google's push notification service.
Posted Apr 12, 2023 - 15:54 UTC
Monitoring
Around 14:03 UTC we began to see a marked decrease in errors in delivering push notifications to devices. As of 14:15 UTC we have cleared our backlog of notifications that queued during the course of the incident, and are now delivering notifications within a timely manner.

At this time we believe the root cause of this issue was due to an increase in error rates seen by Google's notification service.
Posted Apr 12, 2023 - 14:24 UTC
Update
We have put in place a mitigation at 13:28 UTC to ensure that inbound messages are delivered to customers in a timely manner. We are still seeing delays in sending push notifications to user devices at this time.
Posted Apr 12, 2023 - 13:44 UTC
Investigating
Beginning around 13:12 UTC we started experiencing delays in integrating driver messages to customer web services. We are also investigating delays in delivering push notifications to drivers.

We are investigating and will provide an update in 20 minutes or when new information.
Posted Apr 12, 2023 - 13:28 UTC
This incident affected: Eleos Platform (Mobile Apps).