Error Rates Elevated

Incident Report for Eleos Technologies

Postmortem

We have completed the backfill of driver current location information for historical trip plans. The driver’s current location will now be displayed in Trip Planner Studio in App Manager on user navigation routes. If trip plans were retrieved via the Trip Plans API endpoints during the time that the backfill was in progress (6/7/2026 16:28 UTC - 6/8/2026 14:45 UTC), pull the snapshot from the API again to have the trip_plan.stops.user_navigation_location property populated. If you experience any issues or have questions, please reach out to Eleos Support.

We will provide an incident report on the status page once we complete our investigation.

Posted Jun 08, 2026 - 15:47 UTC

Resolved

We are working through backfilling data affected by this issue. At the moment, it may not be possible to see the starting location of the driver, indicated by an orange pin on user navigation routes, in historical trip plans in Trip Planner Studio in App Manager, or via the trip_plan.stops.user_navigation_location property in the Trip Plans API endpoints. We will continue to backfill data into the upcoming week and we will post a post mortem to the status page once the backfill is complete.
Posted Jun 07, 2026 - 19:34 UTC

Update

We are now working on a fix to restore visibility of the driver's current location in historical trip snapshots. There was no data loss during the incident and new routes will continue to display the current location information. We will also continue to monitor the original mitigation.
Posted Jun 07, 2026 - 16:47 UTC

Monitoring

We applied a fix for the routing issue an have confirmed that routes are now generating. The mitigation has an impact to the display of the driver's current location in historical trip snapshots. We will follow up with additional details about this impact shortly.
Posted Jun 07, 2026 - 16:39 UTC

Update

We are continuing to work on a mitigation for routing issues.
Posted Jun 07, 2026 - 16:28 UTC

Identified

We have identified the issue and are working with Senior Engineering to apply a mitigation. We expect to resolve the issue in an about an hour and will continue to provide updates.
Posted Jun 07, 2026 - 15:57 UTC

Update

We are continuing to investigate the issue. We are experiencing issues generating routes in the mobile app and will update as we learn more.
Posted Jun 07, 2026 - 15:26 UTC

Investigating

The error rate for certain Platform actions is elevated. We’re investigating the cause and impact and will provide details as soon as possible.
Posted Jun 07, 2026 - 14:53 UTC
This incident affected: Eleos Platform (API, App Manager, Mobile Apps, Telematics Integrations, Document Delivery).