Delays in message delivery and notifications

Incident Report for Eleos Technologies

Resolved

We have identified the cause of the notification delay, and are continuing to see notifications processed normally.

Notifications were delayed between the period of 4/3/2026 18:09 UTC and 4/3/2026 18:31 UTC for a total period of 22 minutes.
Posted Apr 03, 2026 - 19:06 UTC

Monitoring

Message notifications are no longer delayed as of 18:32 UTC. Notifications were delayed between the period of 18:09 UTC and 18:31 UTC.

Upon further investigation, messages integrated to messaging services were not delayed. Only message notifications to drivers - including new messages and updating message counts on app icons were delayed during the incident period.
Posted Apr 03, 2026 - 18:46 UTC

Investigating

We are currently investigating possible delays in message notifications to drivers, and delays in integrating messages from drivers to messaging services.

We will provide an update in 20 minutes.
Posted Apr 03, 2026 - 18:28 UTC
This incident affected: Eleos Platform (API, Mobile Apps).