Investigating a problem with retrieving POIs and document delivery

Incident Report for Eleos Technologies

Resolved

We've confirmed that documents are being delivered within normal durations.

Other areas of the mobile app and App Manager are operating normally.

We apologize for the disruption in service. If you have further concerns, please reach out at support@eleostech.com.
Posted Oct 20, 2025 - 20:34 UTC

Update

Our document delivery backlog has caught up and we're processing incoming documents at a normal rate. We're continuing to monitor delivery times to ensure they've returned to normal durations.

POI layer loading and pin move recommendation issues have resolved. Drivers should not see errors when loading POI layers in the mobile app.

We'll provide another update by 4:40 PM EDT for document delivery as that continues to return to normal operation.
Posted Oct 20, 2025 - 20:20 UTC

Update

We're continuing to work through the document delivery backlog. POI layers are continuing to have issues loading in the mobile app.

We're continuing to monitor and we'll provide another update by 4:35 PM EDT.
Posted Oct 20, 2025 - 20:05 UTC

Update

Our document delivery system is continuing to catch up with its backlog. POI layers is continuing to have issues loading in the mobile app.

We're continuing to monitor and we'll provide another update by 4:05 PM EDT.
Posted Oct 20, 2025 - 19:35 UTC

Monitoring

Our upstream provider has applied their mitigation and we're now seeing significant improvements in document processing times. Our systems are currently working through the backlog of pending document deliveries.

POI layer loading is not yet improved.

We'll continue to monitor as we catch up with the document delivery backlog and provide another update by 3:30 PM EDT.
Posted Oct 20, 2025 - 19:00 UTC

Update

We're continuing to prep our fallback mitigation while our service provider works on fixing the underlying issue. We're still seeing documents delivered with delays, as well as degraded POI layer loading. Other areas of the mobile apps continue to be unaffected.

We'll share another update by 3:15 PM EDT.
Posted Oct 20, 2025 - 18:33 UTC

Update

Our upstream provider is applying a mitigation and reports seeing an early indication of improvements. These improvements have not yet had an effect on the Eleos Platform, but we're continuing to monitor and work on a fallback mitigation.

Document delivery and POI layers are still affected with degraded performance.

We'll provide another update by 2:30 PM EDT
Posted Oct 20, 2025 - 17:57 UTC

Update

Our upstream provider is currently in the process of validating a fix for their capacity issues .

We continue to process documents at a reduced rate; at this time, we are delivering all documents within 90 minutes of sending, and most within an hour of sending.

POI layer loading is still operating at a degraded level.

We'll post another update by 1:45 PM EDT.
Posted Oct 20, 2025 - 17:19 UTC

Update

Our upstream provider is continuing to resolve the underlying issue, which is manifesting in our systems as reduced computing capacity.

We continue to process documents at a reduced rate; at this time, we are delivering all documents within 90 minutes of sending, and most within an hour of sending.

POI layer loading is still operating at a degraded level.

We are still investigating and preparing mitigation options. We'll post another update by 1:15 PM EDT.
Posted Oct 20, 2025 - 16:36 UTC

Update

After investigating a potential message delivery issue, we have determined that we are successfully delivering messages and that it is not affected by the other issues.

Document delivery and POI layer loading are both still affected. Documents continue to be delivered within 60 minutes of sending.

We're continuing to investigate mitigation options while the upstream provider works on the underlying issue. We'll post another update by 12:20 PM EDT.

Please note that this status page appears to be affected by the ongoing issues and updates may be delayed as a result.
Posted Oct 20, 2025 - 15:53 UTC

Update

Our upstream provider is still working to resolve the underlying issue. We're continuing to investigate mitigations for document delivery and POI layer loading. We have confirmed that while document delivery is delayed, documents are being delivered within 60 minutes.

Additionally, we have observed a delay in message delivery. We're investigating this and will provide more details. We'll provide another update by 11:50 AM EDT.
Posted Oct 20, 2025 - 15:23 UTC

Update

We're continuing to investigate mitigations for document delivery and POI layer issues. We'll update again by 11:15 AM EDT.
Posted Oct 20, 2025 - 14:48 UTC

Update

The issue affecting POI retrieval and pin move recommendations stems from issues with an upstream provider.

Additionally, these issues are now affecting document delivery, which is currently delayed. Any delayed documents are stored and delivery will be retried when the service issue has been resolved.

We're continuing to evaluate potential mitigations and will update again by 10:45 AM EDT.
Posted Oct 20, 2025 - 14:13 UTC

Identified

We've identified the issue affecting the mobile app. A portion of POI layers and pin move recommendations will not load in the mobile app. The rest of the app will continue to function as normal, including trip planning features such as adding non-POI stops, routing, and navigation.

We're working to mitigate the issue and will update again by 10 AM EDT.
Posted Oct 20, 2025 - 13:41 UTC

Investigating

We are investigating potential issues with retrieving POIs in the Eleos mobile app. Our on-call team is engaged and will provide an update shortly.
Posted Oct 20, 2025 - 13:07 UTC
This incident affected: Eleos Platform (Mobile Apps, Document Delivery).