Monitoring delayed message processing

Incident Report for Eleos Technologies

Resolved

Messages integrated successfully and the message backlog remains stable.
Posted Apr 16, 2025 - 20:03 UTC

Update

We remain caught up on our backlog of messages. We are assessing if all messages that were cleared from the backlog have been fully integrated. At this time it appears so, but we want to confirm using a separate source of data.
Posted Apr 16, 2025 - 19:31 UTC

Update

We have completed processing all messages in our backlog. We will continue to monitor the backlog to ensure the queue is stable and messages are no longer being delayed.
Posted Apr 16, 2025 - 18:56 UTC

Update

We are still monitoring messages being sent from the driver to customer backend services. No message information has been lost and workflow actions have not been impacted. We are continuing to see a decrease in the backlog and working on solutions to get through the backlog faster.
Posted Apr 16, 2025 - 18:28 UTC

Update

We are continuing to monitor messages being sent from the driver to customer backend services. Still no message information has been lost during this time as we work through our backlog of messages. Workflow actions have not been impacted during this time. We are successfully processing and delivering messages and are seeing our backlog decrease steadily.
Posted Apr 16, 2025 - 17:54 UTC

Update

We are continuing to monitor messages being sent from the driver to customer backend services. As we continue to work through the backlog of messages, we are also implementing mitigations to increase the system's ability to work through the backlog faster. Still no message information has been lost during this time.
Posted Apr 16, 2025 - 17:14 UTC

Update

We are monitoring our sub-system for sending messages from the driver to customer backend services. We are successfully integrating messages at this time to customer backend web services but we are currently working through the backlog of messages that we do have. No message information has been lost during this time. We will continue to monitor until we have successfully integrated all messages in our queue.
Posted Apr 16, 2025 - 16:41 UTC

Monitoring

We are currently monitoring our backlog of messages. Messages are being processed and we are working through a large backlog that has been queued.
Posted Apr 16, 2025 - 16:07 UTC

Update

We are continuing to work on applying the mitigation and will notify once complete.
Posted Apr 16, 2025 - 15:29 UTC

Update

We have identified the cause of the issue and are working on a mitigation.
Posted Apr 16, 2025 - 14:56 UTC

Investigating

We are investigating a delay in the delivery time of transactions. Our on-call team is engaged and will provide an update shortly.
Posted Apr 16, 2025 - 14:28 UTC
This incident affected: Eleos Platform (Mobile Apps).