Intermittent duplicate outbound messages
Incident Report for Eleos Technologies
Resolved
As of 22:18 UTC we completed the rollback of the infrastructure change that caused the errant behavior, and have confirmed that messages submitted to the API more than once behave as expected.

The rollback of this infrastructure change should not cause any unexpected behavior or changes in functionality of the Eleos Mobile Platform.
Posted Nov 03, 2023 - 22:41 UTC
Identified
We've identified an issue that can cause outbound messages sent using the API to appear as duplicates in the mobile app.

In addition, change updates (delivered via the inbound message API) for these messages may be delivered multiple times with a single client handle, but with different message UUIDs, one per duplicate.

This change specifically affects messages that are submitted to the API more than once. This should normally be permitted without resulting in duplicates, but a recent infrastructure change caused this functionality to not work correctly resulting in duplicate messages seen by users within the app. We are rolling back the change.
Posted Nov 03, 2023 - 22:21 UTC
This incident affected: Eleos Platform (API, Mobile Apps).