Delayed Document Delivery

Incident Report for Eleos Technologies

Resolved

As of 20:44 UTC document delivery times have returned to normal.

Please reach out to support if you have any questions or concerns: support@eleostech.com.

We apologize for the inconvenience.
Posted Jan 29, 2026 - 20:54 UTC

Identified

We have identified the issue and applied a fix, document processing times are starting to resolve.
Posted Jan 29, 2026 - 20:41 UTC

Investigating

We are currently investigating delays with document delivery.
Posted Jan 29, 2026 - 20:23 UTC
This incident affected: Eleos Platform (Document Delivery).